2024-04-16 02:23 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0005108TBL_CapturedDreams[All Projects] Generalpublic2024-03-25 12:37
Reporterransom 
Assigned ToPsygoreProject InfoCaptured Dreams (The Black Lotus)
http://www.whdload.de/demos/TBL_CapturedDreams.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Summary0005108: It seems this demo runs choppy with CPU 68020, but runs fine in 68040 or 60. Is
DescriptionGameVersion: english,pal,2 disks
SlaveVersion: 1.0 from 20.05.2000

It seems this demo runs choppy with CPU 68020, but runs fine in 68040 or 60. Is it at all possible to make it run at full speed in 68020 AGA?
TagsNo tags attached.
MachineA1200
CPU68020
CPUSpeed14
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem4 MB
WorkbenchOS 3.1.4
KickROM46 - Kick 3.1.4
KickSoftNone
WHDLoad18.6
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0009893

StingRay (developer)

The demo has been coded for 030 machines, full speed on 68020 is not possible.

note ~0013169

Torti the Smurf (reporter)

The Slave has no Cache support; right ?

Because "native" , it runs pretty smooth on my setup
but super slow with the Slave.

Please add Cache support.

Thanks,Respect & Greetings,

Torti

note ~0013175

Psygore (developer)

The slave enables already the caches.

Make you sure that you have not nocache option enabled somewhere (icon tooltypes, whd prefs…)

What is your setup when running this demo ?

note ~0013178

Torti the Smurf (reporter)

Hi Psygore. (◠‿◠)

Yup, i even set CACHE as tooltype but it slow as ..... a slug ;)

Mist FPGA latest core (with Chipspeed set to BOTH)
Winuae 1200 030 50mhz config

Its always the same;
its super slow with the WHDLoad slave but pretty smooth when run native.

Like the Slave would not trigger CACHE.

Odd

note ~0013179

Psygore (developer)

The cpu caches on 030 were set only if there was an enabled MMU.

Attached new slave, caches will be set on 030 without MMU now.

note ~0013183

Torti the Smurf (reporter)

Makes sense now; i dont have/use a MMU (◠‿◠)

Works now in "full speed" !!

That Saved me, because native the Minimig core froze/stuck at the Dophin Scene.

Thank you so very much Psygore !!!

This is one of those TBL classics that i also saw back in the day and i just
love that Zoooooooom effect. ٩(^‿^)۶


Reminds me of this part in another demo years later ;)
https://www.youtube.com/watch?v=IhSb73KVe28&t=400s

Anyway, much respect, thanks and greetings;
Torti

note ~0013589

Psygore (developer)

New install package available.

note ~0013597

Torti the Smurf (reporter)

Nice! Thanks Psygore \(^o^)/
+Notes

-Issue History
Date Modified Username Field Change
2021-04-08 09:49 administrator New Issue
2021-04-08 09:49 administrator Status new => assigned
2021-04-08 09:49 administrator Assigned To => Psygore
2021-04-08 20:42 StingRay Note Added: 0009893
2023-09-01 16:04 Torti the Smurf Note Added: 0013169
2023-09-02 16:43 Psygore Note Added: 0013175
2023-09-02 20:59 Torti the Smurf Note Added: 0013178
2023-09-03 19:28 Psygore File Added: CapturedDreams11.lha
2023-09-03 19:31 Psygore Note Added: 0013179
2023-09-06 22:46 Torti the Smurf Note Added: 0013183
2024-02-12 23:56 Psygore Status assigned => resolved
2024-02-12 23:56 Psygore Resolution open => fixed
2024-02-12 23:56 Psygore Note Added: 0013589
2024-02-15 23:41 Torti the Smurf Note Added: 0013597
2024-03-25 12:37 Psygore Status resolved => closed
+Issue History