2024-07-21 09:23 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0006255SuperStreetFighter2[All Projects] Generalpublic2024-03-25 12:37
ReporterTorti the Smurf 
Assigned ToPsygoreProject InfoSuper Street Fighter 2 (US Gold)
http://www.whdload.de/games/SuperStreetFighter2.html
 
PrioritynormalSeverityblockReproducibilitysometimes
StatusclosedResolutionfixed 
Summary0006255: The Intro freezes sometimes, depending on the Chip Speed
DescriptionYupp, the Intro freezes sometimes, (a bit random tho) depending on the Chipspeed & a random factor.... i know the game has some weird checks...

anyway.

Would be cool if you could make an option to skip the intro.

Much love and respect as always,

your testing test smurf,
Torti
TagsNo tags attached.
MachineA1200
CPU68020
CPUSpeed50
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem32 MB
WorkbenchOS 3.9
KickROM40 - Kick 3.1
KickSoftNone
WHDLoad18.9
imported
Attached Files

-Relationships
+Relationships

-Notes

note ~0013506

Torti the Smurf (reporter)

The File AGA.exe or the cracktro PDY-AGA.exe has to be run
before the ssf2.exe.

Even in the native install the game would freeze later on,
when this file was not loaded.

It works also for the WHDload version ..which is a bit weird, but its true.

Just try aga.exe on a real/or fpga amiga and then start the WHDload/DX version.
The Intro will run. No more freeze !!

BTW. would be neat if the Ryu-Floppy punch screen would be removed.
(even when i quiet like it) ;) - i think it would "flow" better without it.

(or make it an option)

The Floppy Screen can be removed with the SSF2.exe HD command.

Greetings,
Torti

note ~0013511

Torti the Smurf (reporter)

Correction: it ONLY works with PDY-AGA.exe file. Sorry (T_T)

(the original AGA.exe steals almost ALL the Fast-Ram and then the slave would not boot)

note ~0013532

Psygore (developer)

Thanks for your bug report.

Attached a new slave, it should work fine now, no more freeze.

Added some customs options to skip intro and Ryu floppy disk pic displaying.

note ~0013538

Torti the Smurf (reporter)

Thank you very much Psy !

Very well done !

Greez, Torti

note ~0013545

Torti the Smurf (reporter)

PS: Did alot of "testing" with the new SSF2 slave.

Found some small issues.

1) The Highscore Saving dont work anymore - It saves but none of the names are really saved. (not a big deal, just wanted to report it)

2) with the new slave there are more slowdowns - you can see it when "larger" characters are on sceen and they see stars, or especially when you move the gamespeed all the way up (8 stars). The older was faster.

As for know, i really enjoy the new slave. The Intro skip is neat and no more Ruy that punches that floppy Disk:)

Thank you Psygore !

note ~0013547

Psygore (developer)

Attached a new slave, it will fix the latest issues.

note ~0013548

Torti the Smurf (reporter)

Cool. Thanks Psy \(^-^)/

note ~0013549

Torti the Smurf (reporter)

Hmmmmm, The Hiscores wont save.

(maybe, its because i use the DX version -
You know, the one hack that Boo Boo & Viddi did)

https://mega.nz/folder/gdozjZxL#uI5SheetsAd-NYKMeRjf2A

It has nicer colours ;)

The Slowdowns on Lower Chipspeed got worse.

Ohh well, i think i stick to the slave you posted previously ;)

Greetings & thanks
Torti

note ~0013550

Psygore (developer)

Did you upload the attached lha slave (25.01.24) and try it ?

The DX version is the same executable only data are modified.
The slave checks the crc of the executable, if it unknowns the slave quits with an message error (not supported).

note ~0013552

Torti the Smurf (reporter)

Hi Psy.

I only downloaded the Slaves ... you know, the one you have uploaded ;)

The DX exe is the same; i though maybe, just maybe;
the data hack might had influenced something.
 
No big deal to not have the Hisgscores saved.
(sure it would be neat, but is not essential)

greetz, Torti

note ~0013562

Psygore (developer)

Attached a new slave, hiscores saving should work now.

note ~0013565

Torti the Smurf (reporter)

Perfect !

Works like a charm !

Thank you very much Psygore !!!

greetings,
Torti the test Smurf ;)

note ~0013567

Torti the Smurf (reporter)

Found another small thing. Must be a typo in the slave call.

When finishing the game with Sagat, the slave calls for a file.....
saggat.end BUT it is called sagat.end originally.

Well, just renaming the file fixes that :)

Greetings

note ~0013580

Psygore (developer)

Thanks for the report.

The typo is into the executable game (aga and ecs).

The new slaves will try to load 'saggat.end' first.
If not found, it will load 'sagat.end' (for both versions).

Attached new slaves.

note ~0013591

Psygore (developer)

New install package available.
+Notes

-Issue History
Date Modified Username Field Change
2023-09-12 20:37 Torti the Smurf New Issue
2023-09-13 19:48 StingRay Assigned To => Psygore
2023-09-13 19:48 StingRay Status new => assigned
2024-01-14 20:02 Torti the Smurf Note Added: 0013506
2024-01-15 17:00 Torti the Smurf Note Added: 0013511
2024-01-22 17:39 Psygore File Added: SSF2-12.lha
2024-01-22 17:44 Psygore Note Added: 0013532
2024-01-23 00:31 Torti the Smurf Note Added: 0013538
2024-01-24 17:27 Torti the Smurf Note Added: 0013545
2024-01-25 09:04 Psygore File Deleted: SSF2-12.lha
2024-01-25 09:04 Psygore File Added: SSF2-12.lha
2024-01-25 09:05 Psygore Note Added: 0013547
2024-01-25 10:05 Torti the Smurf Note Added: 0013548
2024-01-25 15:11 Torti the Smurf Note Added: 0013549
2024-01-27 16:50 Psygore Note Added: 0013550
2024-01-28 01:50 Torti the Smurf Note Added: 0013552
2024-01-29 20:59 Psygore File Deleted: SSF2-12.lha
2024-01-29 20:59 Psygore File Added: SSF2-12b.lha
2024-01-29 21:00 Psygore Note Added: 0013562
2024-01-30 19:36 Torti the Smurf Note Added: 0013565
2024-01-31 14:41 Torti the Smurf Note Added: 0013567
2024-02-04 20:00 Psygore Note Added: 0013580
2024-02-04 20:00 Psygore File Deleted: SSF2-12b.lha
2024-02-04 20:00 Psygore File Added: SSF2-12.lha
2024-02-12 23:58 Psygore Status assigned => resolved
2024-02-12 23:58 Psygore Resolution open => fixed
2024-02-12 23:58 Psygore Note Added: 0013591
2024-03-25 12:37 Psygore Status resolved => closed
+Issue History