WHDLoad MantisBT - Driller
View Issue Details
0005761Driller[All Projects] Generalpublic2022-08-05 17:542022-08-25 21:25
ReporterPascal De Maeseneire 
Assigned ToJOTD 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionreopened 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
MachineA500
CPU68000
CPUSpeed14
ChipSetECS
GFXCardNone
ChipMem1 MB
FastMem7MB
WorkbenchOS 3.1.4
KickROM46 - Kick 3.1.4
KickSoftNone
WHDLoad18.8
importedyes
Summary0005761: <span class="mention">https://whdload.de/mantis/view_user_page.php?id=13</span> Hi, I just finish to test Your Latest slave 2.1 I have a message error
DescriptionGameVersion: pal, 1 disk FROM SPS 2498 (Retail v1.0)
SlaveVersion: version 2.1 (02.08.2022) done by JOTD

@JOTD
Hi,
I just finish to test Your Latest slave 2.1
I have a message error with the SPS 2498 Version ONLY (With SPS 2256 it works correctly).
TEST WITH WINUAE 4.9.1
I Have this message after the intro screen when the game start:
Exception "Illegal Instruction " ($10)
At S98224C4 (Task 'Initial CLI' , ExpMem $5E4(4) occured.
Please Could You have a look.
TEST ON MY REAL A500 ACA500PLUS :
Same Way but with a different message :
Exception "Address Error " ($F00C)
PC = $A584A0 (Task 'Initial CLI' , ExpMem $5E4A0) occured.
All tests with differents speed regulation and with differents ToolTypes :
NOCACHE, NOAUTOVEC, NOVBRMOVE, EXPLOCAL (FOR A500ACA500PLUS)
Many Thanks,
Best regards,
Pascal
TagsNo tags attached.
Attached Files

Notes
(0011659)
Pascal De Maeseneire   
2022-08-05 22:21   
CORRECTION :

UNDER WINUAE :

I Have this message after the intro screen when the game start:

Exception "Illegal Instruction " ($10)
at $9824C4 (Task 'Initial CLI' , ExpMem $5E4(4) occured.

The problem starts just before choosing the language version and when manual protection asks you for an answer.

These version (SPS 2498) was probably not supported before...

Best regards,
Pascal
(0011691)
Pascal De Maeseneire   
2022-08-11 12:59   
@JOTD,
Hi,
Please, Could You publish Your Latest corrected Slave (Probably v2.2).
Many Thanks,
Pascal
(0011729)
Pascal De Maeseneire   
2022-08-25 21:25   
@JOTD
Hi,
Many thanks for Your Latest Slave 2.2, it works correctly with SPS 2498 (Multi Languages versions).
But I have a Question :
You Have remove The language selection and the Manual Protection.
Is the multi languages menu is only for the manual protection ?
Any other part of the game work is in local language ?
It seems that the rest of the game works only in english, Is it True ?
If Yes You can Close that report.
Many Thanks,
Best Regards,
Pascal

Issue History
2022-08-05 17:54administratorNew Issue
2022-08-05 17:54administratorStatusnew => assigned
2022-08-05 17:54administratorAssigned To => JOTD
2022-08-05 22:21Pascal De MaeseneireNote Added: 0011659
2022-08-07 14:59JOTDStatusassigned => closed
2022-08-07 14:59JOTDResolutionopen => fixed
2022-08-11 12:59Pascal De MaeseneireStatusclosed => feedback
2022-08-11 12:59Pascal De MaeseneireResolutionfixed => reopened
2022-08-11 12:59Pascal De MaeseneireNote Added: 0011691
2022-08-25 21:25Pascal De MaeseneireNote Added: 0011729
2022-08-25 21:25Pascal De MaeseneireStatusfeedback => assigned