2024-05-29 19:10 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002908Arcane_ThePinkCircle[All Projects] Generalpublic2018-10-12 12:37
ReporterPsygore 
Assigned ToStingRayProject InfoThe Pink Circle (Arcane)
http://www.whdload.de/demos/Arcane_ThePinkCircle.html
 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Summary0002908: When the demo exits at end, there is a message error: FullChip option detects
DescriptionGameVersion: xmas cd
SlaveVersion: version 1.00 (23.09.2013)

When the demo exits at end, there is a message error:
FullChip option detects that memory has been trashed between $80000 and $8000DF.
Surely a wrong blitter operation which corrupts outside basemem.
Snoop option should find the faulty blitop.
TagsNo tags attached.
MachineA1200
CPU68060
CPUSpeed66
ChipSetAGA
GFXCardVoodoo3/Mediator
ChipMem2 MB
FastMem64 MB
WorkbenchOS 3.9
KickROM40 - Kick 3.1
KickSoftSelfmade
WHDLoad17.3beta
importedyes
Attached Files

-Relationships
+Relationships

-Notes

note ~0003628

StingRay (developer)

Thanks for reporting, this was caused by a bug in the bounding box calculation used for the fill and clear routines, I have added a boundary check now which fixes this problem.

note ~0003630

Psygore (manager)

Thanks for fast update, no more memory trash.
Just to inform you that I have the 'green color cycle copper screen' before it returns back to the workbench at the demo end. That means the blitter is busy but dma is off. Expert option must be set to enable this feature.
+Notes

-Issue History
Date Modified Username Field Change
2014-01-03 19:59 administrator New Issue
2014-01-03 19:59 administrator Status new => assigned
2014-01-03 19:59 administrator Assigned To => StingRay
2014-01-04 01:49 StingRay Note Added: 0003628
2014-01-04 01:49 StingRay Status assigned => resolved
2014-01-04 01:49 StingRay Resolution open => fixed
2014-01-04 21:41 Psygore Note Added: 0003630
2018-10-12 12:37 StingRay Status resolved => closed
+Issue History