2024-06-13 15:23 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0006186WHDLoad Installs Gamesinstall scriptpublic2024-02-25 10:32
ReporterSnoopy1234 
Assigned ToStingRayProject InfoWHDLoad Installs for Games
http://whdload.de/download.html
 
PriorityhighSeverityfeatureReproducibilityN/A
StatusfeedbackResolutionreopened 
Summary0006186: Request: Willow SPS[3090] WHDL install
DescriptionI'm requesting an install for Willow by Mindscape - SPS [3090]
Steps To ReproduceN/A
TagsNo tags attached.
MachineA1200
CPU68030
CPUSpeed40
ChipSetAGA
GFXCardNone
ChipMem2 MB
FastMem64 MB
WorkbenchOS 3.9
KickROM40 - Kick 3.1
KickSoftNone
WHDLoad18.9
imported
Attached Files

-Relationships
duplicate of 0006426closedStingRay Willow (Mindscape) 
+Relationships

-Notes

note ~0012921

Snoopy1234 (reporter)

Stingray ?

note ~0012924

StingRay (developer)

What am I supposed to answer here? This patch is in progress as can be seen in the WIP section on the WHDLoad site and will be finished one day. Currently it is not so you have to wait. The game uses a rather complex and not easy to follow file loading routine that incorporates a decruncher, and I need to decipher that as I refuse to release a patch that works with a 512 bytes sector loader patch.

note ~0013298

Snoopy1234 (reporter)

Fluxengine has options to image an Amiga disk at 512 bytes sectors or 528 bytes sectors with Metadata.

If the WHDL imager read 528 byte sectors would the slave be able to allow for the Willow 512 byte decruncher to function?

note ~0013301

StingRay (developer)

Unfortunately, this will not help. The problem with Willow is that it uses a very slow loader that just loads 512 bytes chunks data and decrunches that data as well, i.e. the decruncher code is incorporated into the loader code. So far I have not been able to locate/extract the decruncher code as the code is quite convoluted and not easy to follow. This prevents me from creating a file based patch that just loads files that have been extracted with RawDIC during installation. I do have a version that uses a disk image and works from HD but it is way too slow and completely unusable if "PRELOAD" is not used.

A few months back I invested a lot of time in analysing the Willow code (again), but didn't come up with any usable result. I will probably get back to it during winter.
+Notes

-Issue History
Date Modified Username Field Change
2023-06-12 06:26 Snoopy1234 New Issue
2023-06-19 13:41 Snoopy1234 Note Added: 0012921
2023-06-19 18:08 StingRay Note Added: 0012924
2023-06-19 18:09 StingRay Assigned To => StingRay
2023-06-19 18:09 StingRay Status new => closed
2023-06-19 18:09 StingRay Resolution open => suspended
2023-11-17 05:04 Snoopy1234 Status closed => feedback
2023-11-17 05:04 Snoopy1234 Resolution suspended => reopened
2023-11-17 05:04 Snoopy1234 Note Added: 0013298
2023-11-17 21:22 StingRay Note Added: 0013301
2024-02-25 10:32 StingRay Relationship added duplicate of 0006426
+Issue History